MySQL Workbench 8 unsupported operating system for Linux Mint

After installation of latest MySQL Workbench downloaded directly from the MySQL site an warning is raised during the start of the application:

unsupported operating system

mysql-unsupported-operating-system

The text is:

Unsupported Operating System

You are running Workbench on an unsupported operating system. While it
may work for you just fine, it wasn't designed to run on your platform.
Please keep this in mind if you run into problems.

The list of supported systems can be found here: Supported Platforms: MySQL Workbench

This is the list of the supported OS by MySQL workbench 8:

8.0
Operating System Architecture
Oracle Linux 7 / Red Hat Enterprise Linux 7 / CentOS 7 x86_64
Ubuntu 18.04 LTS x86_64
Windows Server 2016 x86_64
Windows 10 x86_64
macOS 10.13 x86_64
Generic Linux (tar format) x86_32, x86_64, glibc 2.12, libstdc++ 4.4
Fedora Yum Repo  

Linux Mint is not presented but so far not problems are found. So you can work fine using Linux Mint 19 and MySQL workbench 8. In order to mute the message just press: Don't show this message again.

Related Article