Error TLP 1.1-1 On Ubuntu 16.04 LTS and Linux Mint

Problem

Upgrading of TLP 1.0-1 to TLP 1.1-1 gives error:

Preparing to unpack .../tlp-rdw_1.1-1~trusty_all.deb ...
dpkg-maintscript-helper: error: last version is missing
dpkg: error processing archive /var/cache/apt/archives/tlp-rdw_1.1-1~trusty_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
dpkg-maintscript-helper: error: last version is missing
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/tlp-rdw_1.1-1~trusty_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Workaround Remove TLP

I was not able to find a solution and to update to the new version. While trying to remove I got an error:

sudo apt-get remove tlp

sudo add-apt-repository --remove ppa:linrunner/tlp

“Package is in a very bad inconsistent state”

So I had to run:

sudo dpkg --remove --force-remove-reinstreq tlp tlp-rdw

After that I was able to do clean install only of TLP from Software manager. It seems that there is a problem with tlp-rdw.

How to check if TLP is installed ?

You can do it by tlp-stat:

sudo apt-cache policy tlp

How to check if TLP is running ?

You can do it by tlp-stat:

sudo tlp-stat

Update - On 28 January new update 1.1-2 was released which seems to fix the old problem.

Related Article